[Arm-netbook] EOMA68-A20, MD 1.7 severe Power Problems

Luke Kenneth Casson Leighton lkcl at lkcl.net
Tue Aug 11 12:47:51 BST 2020

On Tue, Aug 11, 2020 at 12:35 PM Pablo Rath <pablo at parobalth.org> wrote:

> On Tue, Aug 11, 2020 at 11:37:41AM +0100, Luke Kenneth Casson Leighton wrote:

> Ok. I have tried that now. Pressed "2" while applying power over USB-OTG
> but an Allwinner USB FEL device is not found with 'sunxi-fel version'.
> Also tried to boot with my known working µSD-Card but there is no output
> on UART.

hm ok there is one more "trick" - actually uploading (and executing)
the spl bootloader followed by u-boot and everything else

the old version, fel-boot, you had to first "run" then "execute".  the
newer version (sunxi-fel) looks like it does run-and-execute.

the first binary (the spl bootloader) fits into the 16k SRAM and until
that's executed (and it initialises the PLL and DDR3) there's flat-out
no chance of uploading anything at all into the upper areas of memory
(0x42000000) which are in the DDR3 RAM area.

i have in the past set up a linux kernel to convert the USB-OTG into a
usbserial "gadget", and also a usbnet-compatible g_ether "gadget".
the first way was successful in showing early console logs, and the
second was enough to get a USB eth0 that i could ssh in over.


More information about the arm-netbook mailing list